通达信买卖点主图指标无未来函数,请高手帮助修改下面通达信有未来函数指标为无未来函数?

内容导航:
  • 请高手帮助修改下面通达信有未来函数指标为无未来函数?
  • 谁有无未来高抛低吸主图指标公式?
  • 通达信分笔指标,比较准确,不含未来函数,怎么做到的
  • 不含未来函数“通达信”指标
  • 关于通达信BUYBARS函数得应用
  • 这个通达信公式高手看看如何,能否改成条件选股公式,如果能去掉未来函数最好多谢了
  • Q1:请高手帮助修改下面通达信有未来函数指标为无未来函数?

    首先这代码没有未来函数,再有就算有未来函数改成不是未来函数,那结果也不一样啊,就算有些指标不用未来函数写出同样的结果效果一样是未来函数没有意义。

    Q2:谁有无未来高抛低吸主图指标公式?

    你的公式没有未来函数,这个是卖点主图公式
    阻挡:=(SMA(HIGH,13,2) * 1.04);
    DRAWTEXT((((CLOSE < REF(CLOSE,1)) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),h,'卖'),COLORFF00FF;

    Q3:通达信分笔指标,比较准确,不含未来函数,怎么做到的

    个人认为,缠论的分笔指标,如果一定要用公式表达,使用未来函数是不可避免的,主要使用zig,以及PEAKBARS(峰顶),TROUGHBARS(峰谷)指标。
    对于缠论,没必要太在意所畏的背驰,关键是它所描述的时间分级别、线段趋势打断这才是关键。如果是下跌趋势,即使是30分钟背驰,如果没有出现线段方向打断,后面还会有小时级别的背驰,之后还会出现日线级别背,如果这个过程你不幸持仓了,那损失可畏不少。缠论对操作的细节讲得比较模糊,抛出一大堆概念,每个人理解角度不同,会有不同的操作。缠只告诉我K线最基本走势是“之”字形。
    我认为炒股并没有缠所描述这么复杂,多看K线,把现有常用的统计指标和未来函数指理解透,自己动手编写属于自己的指标,你会更深入体会K线的性质,未来函数只起到定位的作用,操作还是要看传统统计函数。
    希望能帮到你~!

    Q4:不含未来函数“通达信”指标

    这人是真没有!
    所有指标都有未来函数。你想想,公式的计算因子是什么?价、量、时间这三个。
    一般公式只对价进行运算,你想想,一个收盘价在没收盘前是不是就是最新价,下一秒可能就是别的数值了,对于下一秒没到前,是不是有未来的嫌疑?稍强点儿的公式就有了量的加入,什么成交量啦、成交金额了等计算因子加入进去,只要没收盘,量和额都有未来的成分。
    更别提时间了,时间是价、量的起因,时间是一把尺子,用来量过去,但不能量未来,一旦在时间上加个1,就有了未来的成分,所以,如果没有好的逻辑来计算时间的话,所有的指标都有未来成分。你的问题太难了!!!

    Q5:关于通达信BUYBARS函数得应用

    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2; 忽略以上公式。 通达信软件“STD”是估算标准差的计算函数,你可以百度查一下就知道原理,至于如何实现,这是软件的功能,算术中很多计算方法在软件中都是用函数代替。

    Q6:这个通达信公式高手看看如何,能否改成条件选股公式,如果能去掉未来函数最好多谢了

    N:=7;
    A1:=REF(H,N)=HHV(H,2*N+1);
    B1:=FILTER(A1,N);
    C1:=BACKSET(B1,N+1);
    D1:=FILTER(C1,N);{高点}
    A2:=REF(L,N)=LLV(L,2*N+1);
    B2:=FILTER(A2,N);
    C2:=BACKSET(B2,N+1);
    D2:=FILTER(C2,N);{低点}
    E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
    H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
    L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
    X1:=REF(BARSLAST(H1),1)+1;
    F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
    G1:=F1>REF(F1,1);
    I1:=BACKSET(G1,2);
    LD:=I1>REF(I1,1);{过滤后低点}
    L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
    X2:=REF(BARSLAST(L2),1)+1;
    F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
    G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
    R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
    T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
    R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
    T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
    T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
    T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
    R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
    R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
    XG: U1 OR U2 OR U3 OR U4;
    点评:
    这个公式的核心价值就是未来函数。去掉的话,就没有意义了。
    这个主图公式主要是用来观察趋势,而不是用来决定买卖点的。

    上一篇:上一篇:通州圣元股价
    下一篇:下一篇:通达信带股票池版
    • 评论列表

    发表评论: